home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-apps / hotplug-20040923-r2 / hotplug-20040923-r2.ebuild < prev    next >
Text File  |  2006-05-01  |  2KB  |  77 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20040923-r2.ebuild,v 1.1 2006/04/20 00:01:53 wolf31o2 Exp $
  4.  
  5. inherit eutils
  6.  
  7. # source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
  8. MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
  9. S=${WORKDIR}/${MY_P}
  10. DESCRIPTION="USB and PCI hotplug scripts"
  11. HOMEPAGE="http://linux-hotplug.sourceforge.net"
  12. SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
  13.  
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
  17. IUSE=""
  18.  
  19. # hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
  20. DEPEND=">=sys-apps/pciutils-2.1.9
  21.     >=sys-apps/usbutils-0.9
  22.     sys-apps/hotplug-base"
  23.  
  24. src_unpack() {
  25.     unpack ${A}
  26.     cd "${S}"
  27.     epatch "${FILESDIR}"/${PN}-ifrename.patch
  28.     epatch "${FILESDIR}"/${P}-scsi-agent-timeout.patch
  29. }
  30.  
  31. src_install() {
  32.     into /
  33.     doman *.8
  34.     dodoc README README.modules ChangeLog
  35.  
  36.     cd "${S}"/etc/hotplug
  37.     insinto /etc/hotplug
  38.     # Added 2006/04/16 to resolve bug #128962
  39.     echo "" >> blacklist
  40.     echo "# Don't hotplug eth1394, bug #128962" >> blacklist
  41.     echo "eth1394" >> blacklist
  42.     echo "" >> blacklist
  43.     echo "shpchp" >> blacklist
  44.     doins blacklist hotplug.functions *map || die
  45.  
  46.     exeinto /etc/hotplug
  47.     doexe *.agent *.rc *.permissions || die
  48.     # stupid isapnp.rc files...
  49.     newexe "${FILESDIR}"/isapnp.rc.empty isapnp.rc
  50.  
  51.     dodir /usr/lib/hotplug/firmware
  52.     dodir /etc/hotplug/usb
  53.     dodir /etc/hotplug/pci
  54.     cd "${S}"/etc/hotplug.d/default
  55.     exeinto /etc/hotplug.d/default
  56.     doexe default.hotplug || die
  57.  
  58.     newinitd "${FILESDIR}"/hotplug.rc.empty hotplug
  59.     newconfd "${FILESDIR}"/usb.confd usb
  60.     dodir /var/run/usb
  61. }
  62.  
  63. pkg_postinst() {
  64.     ewarn "WARNING: The hotplug init script is now gone (dead and burried.)"
  65.     ewarn "WARNING: If you want to load modules for hardware that was already"
  66.     ewarn "WARNING: discovered at boot time, like the old hotplug init script"
  67.     ewarn "WARNING: did, then emerge the coldplug package, and add coldplug to"
  68.     ewarn "WARNING: a runlevel, e.g. # rc-update add coldplug boot"
  69.     echo
  70.     ewarn "WARNING: All firmware loaded by the hotplug scripts needs to be"
  71.     ewarn "WARNING: moved to the /lib/firmware directory, as the scripts now"
  72.     ewarn "WARNING: expect it to be in that location."
  73.     echo
  74.     ewarn "If you still have the file /etc/hotplug/isapnp.rc on your system,"
  75.     ewarn "please delete it by hand, the file /etc/hotplug/pnp.rc superseeds it."
  76. }
  77.